post Image
【Xcode 8対応版】Xcodeプラグイン Alcatrazを導入しよう

Xcode 8以降を使っている場合、Xcodeプラグイン「Alcatraz」のインストールが少し面倒になりました。
手順を追って説明します。

環境

  • macOS Sierra 10.12.2
  • Xcode 8.2.1

Alcatrazを導入

公式ページに記載があるように、ターミナルを開き以下のコマンドを打ってAlcatrazを導入します。

Terminal
curl -fsSL https://raw.githubusercontent.com/supermarin/Alcatraz/deploy/Scripts/install.sh | sh

通常ならばここでWindow→Package Manager… でパッケージマネージャが出るはずですが、Xcode 8以降の場合は出ません。

update_xcode_plugins をインストール

そこで、update_xcode_pluginsを使います。
ターミナルで、

sudo gem install update_xcode_plugins

と入力。sudoをつけているのでパスワードが聞かれますので、パスワードも入力。(パスワードは表示されませんが入力されています。)

image

update_xcode_plugins を実行

Xcode 8以上を使っている場合は、この作業が必要です。
ターミナルで、

update_xcode_plugins --unsign

を実行します。
image

途中で、インストールされているXcodeのバージョンを聞かれるので、最新版を選択してEnterをクリック。
最後に、Finish!と表示されれば完了です。
image

Xcodeを起動

通常通りXcodeを起動してみましょう。

スクリーンショット 2017-01-02 21.44.54.png

起動時に、Alcatrazをロードしますかと確認されるので、こちらは「Load Bundle」をクリックします。

無事にWindow→Package Managerが表示され、Package Managerウィンドウが表示されれば完了です!

image

Package Manager画面
image


『 Swift 』Article List